Cập nhật Eclipse bằng các công cụ phát triển Android v. 23

610
greywolf82 2014-06-27 08:21.

Tôi đã cập nhật Eclipse bằng các công cụ SDK mới (phiên bản 23), nhưng bây giờ khi Eclipse khởi động, tôi nhận được lỗi:

SDK Android này yêu cầu Bộ công cụ dành cho nhà phát triển Android phiên bản 23.0.0 trở lên. Phiên bản hiện tại là 22.6.3.v201404151837-1123206. Vui lòng cập nhật ADT lên phiên bản mới nhất.

Không tìm thấy bản cập nhật nào với "Kiểm tra bản cập nhật" . Nếu tôi thử "Cài đặt phần mềm mới" , tôi có thể thấy phiên bản 23, nhưng tôi không thể nâng cấp do lỗi sau:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

Sau khi tải xuống ADT cuối cùng từ trang web, có vẻ như có một vấn đề khác.

Với phiên bản Công cụ SDK. 23 proguard chưa được cài đặt, dir/tools/proguardthiếu SDK thư mục và thiếu các công cụ khác. Phiên bản này có một số lỗi.

30 answers

193
Daniel Diaz 2014-06-27 08:33.

Google đã phát hành ADT v23.0.2. Điều này đã giải quyết nhiều vấn đề của phiên bản ADT 23 trước đó.

Từng bước một:

  • Menu Trợ giúp → Cài đặt Phần mềm Mới ...
  • Đối với "Làm việc với", hãy chọn nguồn Android https://dl-ssl.google.com/android/eclipse
  • Đánh dấu vào ADT v23.0 để cài đặt, sau đó nhấp vào "Tiếp theo"
  • Eclipse sẽ hiển thị "Cài đặt Trang khắc phục" vì có xung đột với phiên bản trước. (Nếu không, hãy xem bên dưới.) Chọn "Cập nhật cài đặt của tôi để tương thích với các mục đang được cài đặt" để gỡ cài đặt phiên bản cũ và cài đặt phiên bản mới. Sau đó, tiến hành các bước thông thường.

Lưu ý: Khi tôi cài đặt phiên bản mới của ADT, tôi không bao gồm phiên bản mới của gói "Công cụ phát triển bản địa của Android". Thay vào đó, tôi đã cài đặt phần còn lại của các gói trước, sau đó cài đặt "Công cụ phát triển bản địa của Android". Vì một lý do nào đó, nếu tôi cố gắng cài đặt tất cả các gói mới bao gồm "Công cụ phát triển bản địa của Android", quá trình cài đặt không thành công.

Nếu không có "Trang khắc phục sự cố", cách duy nhất để xóa plugin ADT khỏi Eclipse là đi tới menu Trợ giúpGiới thiệu về EclipseChi tiết cài đặt và gỡ cài đặt từ đó . Nhưng có nguy cơ gỡ cài đặt chính Eclipse.

114
greywolf82 2014-06-28 05:35.

Phản hồi của Google :

Đây là một lỗi đóng gói. Toàn bộ tệp proguard bị thiếu. Chúng tôi sẽ có bản cập nhật càng sớm càng tốt, nhưng chỉ cần sao chép nó từ phiên bản trước của các công cụ:

và sao chép các tệp sau:

  • công cụ / hprof-chuyển đổi
  • tools / support / annotations.jar
  • công cụ / proguard

Vì vậy, cuối cùng nếu bạn bắt đầu từ một ADT mới, hãy sao chép thủ công các tệp :)

Chỉnh sửa: với bản phát hành ADT mới nhất, gói hiện sẽ hoạt động với tính năng tự động cập nhật, vì vậy hãy cài đặt các phiên bản mới sau:

Đừng cố nâng cấp từ phiên bản trước vì nó không hoạt động chút nào. Nếu bạn gặp sự cố với zipalign, nó hiện đang ở dưới công cụ xây dựng và không còn ở dưới công cụ / vì vậy bạn có thể tạo một liên kết tượng trưng hoặc chỉ cần sao chép nó vào thư mục mong đợi.

53
dennisdrew 2014-06-27 10:56.

Không có câu trả lời nào khác phù hợp với tôi khi sử dụng gói ADT được xuất bản trên developer.android.com.

Tôi đã kết thúc việc tải xuống phiên bản mới nhất của Eclipse ( không phải gói ADT ) và sau đó cài đặt plugin ADT qua menu Trợ giúpCài đặt phần mềm mới → nhập https://dl-ssl.google.com/android/eclipse(được đề cập bởi @RED_).

Tôi cũng phải cập nhật không gian làm việc của mình để trỏ đến không gian làm việc trước đó của mình và hầu hết mọi thứ dường như đã được khôi phục.

Một lưu ý nhỏ: Đây có vẻ là thời điểm thích hợp để chuyển sang Android Studio ...

52
Kartheek s 2014-06-27 23:41.

LƯU Ý: Sử dụng phương pháp này một cách thận trọng vì điều này có thể phá vỡ cài đặt Eclipse của bạn (xem nhận xét) .

Điều này có thể hữu ích nếu bạn cài đặt plugin ADT theo cách thủ công . Nhưng nếu bạn đang sử dụng phiên bản Eclipse từ Gói ADT Eclipse, các bước dưới đây có thể phá vỡ cài đặt Eclipse của bạn và bạn có thể không sử dụng lại Eclipse!

Đi đến

Menu Trợ giúpGiới thiệu về Eclipse SDKInstallation Details.

Bây giờ bạn sẽ thấy tất cả các 22.0phiên bản và sau đó nhấp vào Uninstallnút ở dưới cùng.

Sau khi gỡ cài đặt goto:

Menu Trợ giúpCài đặt phần mềm mới → nhậphttp://dl-ssl.google.com/android/eclipse/

Sau đó, cài đặt tất cả mọi thứ, và bây giờ nó đã sẵn sàng.

18
wi1 2014-06-28 06:45.

Tôi đã cập nhật máy chủ xây dựng của mình hôm nay và gặp phải vấn đề tương tự. Nó đã được báo cáo tại đây: https://code.google.com/p/android/issues/detail?id=72419

Bản sửa lỗi đang được tiến hành và công việc xung quanh theo người quản lý dự án là:

Vui lòng đợi phiên bản cập nhật trong vòng một hoặc hai ngày. Cho đến lúc đó, cách giải quyết của bạn là tải xuống một trong các

http://dl.google.com/android/android-sdk_r22.6.2-linux.tgz

http://dl.google.com/android/android-sdk_r22.6.2-windows.zip

http://dl.google.com/android/android-sdk_r22.6.2-macosx.zip

và sao chép các tệp sau:

    tools/hprof-conv
    tools/support/annotations.jar
    tools/proguard

[sửa] tôi cũng thiếu zipalign, hãy kiểm tra xem bạn có cần sao chép tệp này không

17
Arsalan Mehmood 2014-06-30 10:56.

Nó phù hợp với tôi :)

Nếu vì lý do nào đó bạn đã cài đặt bản xem trước ADT và cần hoàn nguyên về trạng thái ổn định hiện tại, bạn không thể sử dụng hộp thoại để cài đặt phần mềm "mới" vì thứ bạn muốn thực sự là phần mềm cũ hơn. Thay vào đó, hãy làm điều này:

  • Mở Trợ giúp> Giới thiệu về Eclipse ... trên Windows hoặc Linux. Trên Mac, sử dụng menu của ứng dụng> Giới thiệu ...
  • Nhấp vào nút "Chi tiết Cài đặt".
  • Chọn tab "Lịch sử Cài đặt".
  • Chọn một trong các cấu hình trước đó.
  • Nhấp vào nút "Hoàn nguyên" ở dưới cùng.

16
rupesh 2014-07-17 00:00.

là những gì họ đang nói về điều này:

Được rồi, các bạn, xin lỗi về tất cả những rắc rối này và chúng tôi xin lỗi vì các bản phát hành bị rối. Đây là tóm tắt:

Bắt đầu với gói ADT 23.0.2, bạn sẽ có thể cập nhật lên các phiên bản ADT trong tương lai.

Nguồn: https://code.google.com/p/android/issues/detail?id=72912

15
Rajat Sharma 2014-06-27 08:59.

Tôi đã thực hiện sau để giải quyết vấn đề.

  1. Tới http://developer.android.com/sdk/installing/installing-adt.html và tải về các tập tin ZIP ADT mới nhất (ở dưới cùng của trang).

  2. Đi tới Eclipse → menu Trợ giúpGiới thiệu về EclipseChi tiết cài đặt

  3. Xóa Android DDM, Công cụ phát triển Android, Hierarchy Viewer, Công cụ phát triển Native, TraceView vv, phiên bản 22.X .

  4. Menu Trợ giúp * → Cài đặt Phần mềm MớiThêmLưu trữ → * Chọn tệp ZIP đã tải xuống ở bước 1.

  5. Chọn tất cả phiên bản mới nhất của tất cả 23 mà tôi đã xóa ở bước 3 và chấp nhận thỏa thuận cấp phép.

Khởi động lại Eclipse và nó khắc phục sự cố của tôi.

9
Hermann Schwarz 2014-06-28 05:01.

Chỉ giúp:

  1. Cài đặt Eclipse mới ( http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunar )
  2. Trợ giúp -> Cài đặt phần mềm mới -> https://dl-ssl.google.com/android/eclipse/
8
bond 2014-06-27 23:32.

Nếu bạn cài đặt một phiên bản Eclipse mới, nó sẽ hoạt động. Đây là những gì tôi đã làm:

  1. Đã cài đặt phiên bản Eclipse mới, Luna
  2. Tạo một bản sao lưu của không gian làm việc hiện tại.
  3. Chạy Eclipse mới, Luna và cập nhật không gian làm việc
  4. Đã cài đặt plugin ADT (Trợ giúp -> Cài đặt phần mềm mới)
  5. Đã khởi động lại Eclipse
  6. Làm xong
8
Luke Deighton 2014-07-04 04:24.

Có rất nhiều sự nhầm lẫn xung quanh chủ đề này. Có hai giải pháp tùy thuộc vào cách bạn cài đặt ADT.

  1. Nếu bạn đã cài đặt plugin ADT theo cách thủ công thì tôi tin rằng bạn có thể sử dụng cách tiếp cận "Xóa ADT" -> "Cài đặt phần mềm mới".

  2. Nếu bạn đang sử dụng Gói ADT thì đừng làm theo giải pháp đó! Bạn sẽ phá vỡ Eclipse. Đây là bản cập nhật từ một thành viên của Google - đọc # 18:

    https://code.google.com/p/android/issues/detail?id=72912

Bạn phải tải xuống phiên bản mới của ADT-Bundle (vâng, thật khó chịu!).

7
Hrushikesh 2014-06-27 22:57.
  • Chỉ cần gỡ cài đặt ADT trước đó.
  • Đi tới menu Trợ giúpGiới thiệu về EclipseInstallation Details
  • Gỡ cài đặt tất cả các plugin có Id bắt đầu bằng com.android.ide
  • Cài đặt lại ADT từ trang cập nhật.
6
Biljana 2014-06-27 09:50.

KHÔNG LÀM ĐIỀU NÀY

Cảnh báo: Vui lòng xem các bình luận bên dưới câu trả lời này. Những bước này đã có tác động tiêu cực đến nhiều người.

  1. Nhấp vào Trợ giúp / Cài đặt phần mềm mới ...
  2. Nhấp vào Cái gì "đã được cài đặt" (như trong hình bên dưới)
  3. Trong cửa sổ mới, bạn có thể gỡ cài đặt ADT cũ (gỡ cài đặt Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Development Tools và Tracer cho OpenGL ES)
  4. Khởi động lại Eclipse
  5. Sau đó nhấp lại vào Trợ giúp / Cài đặt Phần mềm Mới
  6. Chọn ADT ... Cài đặt

Tôi hy vọng nó sẽ giúp!

5
Alécio Carvalho 2014-06-27 23:44.

Sau khi thử các cách tiếp cận trong các câu trả lời khác mà không thành công, tôi vừa cài đặt một gói mới từ http://developer.android.com/sdk/installing/index.html?pkg=adt và hoạt động tốt.

Làm như sau:

  1. Vì bạn không muốn tải xuống lại tất cả các nền tảng, hãy sao chép nền tảng hiện có từ / OLD_ANDROID_SDK_PATH / sdk / platform sang / NEW_ANDROID_SDK_PATH / sdk / platform .
  2. Khi mở Eclipse mới từ gói đã tải xuống gần đây, hãy đảm bảo rằng bạn sử dụng lại thư mục 'không gian làm việc' trước đó. Điều đó sẽ đảm bảo rằng tất cả các cài đặt trước đó của bạn sẽ được ghi nhớ.
  3. Sau khi mở Eclipse mới trên không gian làm việc trước đó, vui lòng kiểm tra xem SDK Android đã sử dụng có trỏ đến SDK mới hay không (tùy chọn Eclipse -> Android). Nó có thể trỏ đến cái cũ, vì bạn đã sử dụng lại cài đặt không gian làm việc xem trước.

Với các bước này, bạn không cần phải cấu hình lại mọi thứ và bạn sẽ không cần mất thời gian khắc phục sự cố BUG này trên bản nâng cấp này từ Google Developers.

Chúc may mắn! ;-)

5
Andong Zhan 2014-08-09 20:58.

Bạn cần gỡ cài đặt phiên bản cũ và cài đặt 23

gỡ cài đặt: Trợ giúp> giới thiệu về Eclipse SDK> Chi tiết Cài đặt, chọn các gói liên quan đến Android để gỡ cài đặt

Và sau đó cài đặt V23.

4
Ashwin 2014-07-03 22:54.

Không có cách nào để cập nhật gói ADT hiện có mà bạn có thể đã tải xuống.

Bạn có thể thực hiện một trong hai tùy chọn:

  1. Cài đặt Eclipse từ eclipse.org và cài đặt ADT bằng cách trỏ đến trang web cập nhật: https://dl-ssl.google.com/android/eclipse

  2. Tải xuống các gói từ:

Bắt đầu với gói ADT 23.0.2, bạn sẽ có thể cập nhật lên các phiên bản ADT trong tương lai.

3
Derek Gogol 2014-06-28 22:44.

Tôi đã gặp lỗi "phụ thuộc xung đột" tương tự trên Mac OS X 10.9.3 và chỉ cần nâng cấp không phải là một tùy chọn. Điều cuối cùng đã hoạt động là tải xuống tệp zip gói Eclipse ADT mới nhất từ developer.android.com, giải nén nó và chỉ di chuyển thư mục "eclipse" đến nơi chứa thư mục nhật thực cũ của tôi. (giải nén tệp zip gói Eclipse ADT sẽ cung cấp cho bạn các thư mục "eclipse" và "sdk").

Nếu bạn quyết định đi theo cùng một lộ trình, trước tiên hãy đảm bảo rằng bạn biết đường dẫn Không gian làm việc của mình là gì. Điều này có thể được tìm thấy trong Preferences. Sau đó đổi tên thư mục "eclipse" cũ của bạn (không phải Eclipse.app) thành một cái gì đó giống như eclipse-22.6.3, sau đó di chuyển thư mục "eclipse" đã giải nén vào vị trí của nó. Chạy Eclipse.app mới bên trong và khi nó hỏi bạn về Workspace, chỉ cần nhập đường dẫn giống như bạn đã lưu ý ở trên. Hoặc nó cũng có thể được đặt sau trong Preferences.

Có thể đáng để thêm là để bật lại Trình quản lý SDK AndroidTrình quản lý thiết bị ảo Android, hãy chọn Cửa sổ -> Tùy chỉnh Phối cảnh -> Tính khả dụng của Nhóm lệnh và chọn Android SDK và Trình quản lý AVD . Thao tác này sẽ thêm 2 mục này vào mục menu "Cửa sổ" cho phối cảnh hiện tại (Java).

Tôi đã không di chuyển thư mục "sdk" được giải nén, vì tôi đã có thư mục sdk trong cùng thư mục với eclipse, mà tôi đã cập nhật lên các công cụ Android mới nhất. Nhưng nếu điều đó khiến bạn cảm thấy an toàn hơn, bạn cũng có thể đổi tên thư mục sdk cũ của mình (cho mục đích sao lưu) và di chuyển thư mục mới giải nén vào vị trí của nó.

3
user818455 2014-07-03 23:18.

Tôi đã đối mặt với cùng một vấn đề và giải quyết nó. Bạn cần gỡ cài đặt hoàn toàn plugin Android từ bên trong Eclipse (từ phần "giới thiệu" ..), bao gồm cả chế độ xem theo dõi ..

Sau đó, thêm lại Plugin ADT ( https://dl-ssl.google.com/android/eclipse/ ) và cài đặt nó.

Vấn đề đã được giải quyết!

Tôi đoán đó là lỗi với trình quản lý SDK hoặc cơ chế cập nhật Plugin ADT ...

3
Dante 2014-07-31 16:27.

Cách cập nhật từ 22.xx.x lên 23.0.2 (giải pháp của tôi). Điều này sẽ đánh bại các vấn đề phụ thuộc.

Tôi đã bị vấn đề này trong nhiều ngày và tôi đã thử mọi giải pháp trên liên kết này, nhưng không may mắn. Cuối cùng tôi đã tìm ra một giải pháp thực sự hiệu quả!

Xin lưu ý rằng giải pháp này hoạt động trong Windows 7 (64 bit). Nó có thể hoạt động cho các hệ điều hành Windows khác.

Chúng ta bắt đầu:

  1. tải xuống gói ADT mới nhất từ

    http://developer.android.com/sdk/index.html#download

  2. giải nén nó và mở thư mục "eclipse" -> thư mục "plugin"

  3. Bây giờ, hãy chuyển đến nhật thực cũ của bạn và mở thư mục "eclipse" -> thư mục "plugin" và sao chép mọi thứ bên trong.

  4. Bây giờ dán chúng vào thư mục "plugin" của (ECLIPSE MỚI), nhưng KHÔNG ghi đè lên bất kỳ thứ gì.

  5. Khi ở bên trong thư mục "plugin" của Eclipse mới, hãy thực hiện tìm kiếm. Nhập 22.(thông báo 22 có dấu chấm) và nhấn enter.

  6. Kết quả tìm kiếm sẽ hiển thị tất cả các tệp hoặc thư mục có ..... 22,6 ...... Ví dụ:

    com.android.ide.eclipse.adt_**22.6.2**.v201403212031-1085508
    
  7. Đánh dấu tất cả các tệp / thư mục này và nhấn phím xóa.

  8. Đảm bảo cập nhật API / SDK cũ của bạn lên phiên bản mới nhất và tải thư mục sdk này để hoạt động với nhật thực mới của bạn.

hoặc là

Bạn có thể xem video này, video này hướng dẫn bạn cách di chuyển tất cả SDK / API sang thư mục SDK mới của bạn.

Liên kết: https://www.youtube.com/watch?v=jPZpJdnbbN0

Tôi chưa cố gắng cập nhật từ bất kỳ phiên bản ADT nào khác, nhưng tôi nghĩ nó cũng sẽ hoạt động với mọi phiên bản ADT cũ.

Đừng quên sao lưu nội dung trước khi thử.

2
Aman Alam 2014-06-28 01:30.

Những gì tôi vừa tìm thấy là bạn cần cập nhật plugin ADT trong Eclipse của mình (cho dù độc lập hay ADT Bundle) trước khi cập nhật công cụ xây dựng của bạn.

Nếu cài đặt Eclipse của bạn trỏ đến Công cụ xây dựng mới nhất và Eclipse của bạn đang có ADT 22.x, nó sẽ hiển thị các lỗi đó.

Điều gì đã làm việc cho tôi: (trên Ubuntu 14.04 64-bit)

  • Đã cài đặt phiên bản cũ hơn của Eclipse và ADT (từ Gói)
  • Bản sao này của Eclipse đã trỏ đến một xác minh SDK cũ hơn với các công cụ xây dựng cũ (trước 20)
  • Đã cập nhật ADT thành v23 (thông qua kho lưu trữ, trong trường hợp của tôi)
  • Đã trỏ Eclipse đến phiên bản mới nhất của các công cụ xây dựng.

Bạn có thể không có bản sao cũ hơn của các công cụ Eclipse và bản dựng, trong trường hợp đó, bạn có thể gỡ cài đặt công cụ bản dựng mới nhất khỏi Trình quản lý SDK và cài đặt bản sao cũ hơn.
Khi mọi thứ bắt đầu hoạt động tốt, hãy thực hiện các bước trên.

Tôi đang cố gắng tải lên các bản sao cũ hơn của các gói như vậy ở đâu đó trên Internet, sẽ cập nhật các liên kết ở đây, sau khi tôi tải lên xong.

2
danny117 2014-10-08 03:21.

Tôi tìm thấy những hướng dẫn này trong một bình luận.

Tải xuống phiên bản ADT mới nhất và sử dụng không gian làm việc hiện có của bạn. Đây thực sự là lần nâng cấp ít đau đớn nhất mà bạn từng làm. Nó không gây rối với thư mục .android nên tôi vẫn có khóa gỡ lỗi ban đầu của mình. Chỉ có điều còn thiếu là một vài tiện ích bổ sung mà tôi hiếm khi sử dụng và chúng dễ dàng được cài đặt vào phiên bản mới.

Lưu ý không cài đặt vào thư mục adt hiện tại của bạn, hãy tạo một thư mục mới để bạn vẫn có thể quay lại nếu cài đặt mới không hoạt động.

2
stevyhacker 2014-06-27 09:47.

Trên Eclipse kèm theo ADT, trước tiên tôi phải gỡ cài đặt ADT và sau đó thực hiện cài đặt mới.

Để xóa plugin ADT khỏi Eclipse:

  • Đi tới menu Trợ giúpGiới thiệu về EclipseChi tiết Cài đặt .
  • Chọn trình cắm thêm ADT, sau đó nhấp vào Gỡ cài đặt.
  • Sau khi gỡ cài đặt, hãy cài đặt ADT từ Trợ giúp → Cài đặt phần mềm mới.
1
paulgavrikov 2014-06-27 08:37.

Đối với tôi, nó đã giúp xóa Android 4.4W cũng là API 20 và có thể là nguyên nhân gây ra xung đột. Vì vậy, chỉ cài đặt Android 4.4W hoặc Android L cho đến khi họ sửa lỗi.

Và (một lần nữa điều này có thể chỉ dành cho tôi) nó chỉ hoạt động trong Android Studio chứ không phải trong Eclipse ...

1
RED_ 2014-06-27 10:00.

Tôi đã phải xóa ADT và cài đặt lại.

Tuy nhiên, hãy lưu ý rằng , điều này khiến tôi và một người khác gặp lỗi thiếu annotations.jar trong đường dẫn Xây dựng Java cho một số dự án nhất định, có thể vì nó đang cố gắng tìm kiếm một SDK cũ, vì vậy nâng cấp dự án là bước tiếp theo tôi phải làm lấy.

Các lỗi chủ yếu liên quan đến thư viện, Dịch vụ Google Play, SDK Facebook, ActionBarCompat.

Đối với bước này, bạn gỡ cài đặt ADT, sau đó nhập lại URL để tải chúng xuống. Url là:https://dl-ssl.google.com/android/eclipse

1
Samuel Côté 2014-06-27 15:40.

Tôi đã tìm thấy giải pháp cho vấn đề với "sự phụ thuộc xung đột". Tôi không có cùng một trang về câu trả lời của Daniel Díaz, nhưng một trang cho thấy "sự phụ thuộc mâu thuẫn", và tôi không thể làm gì cả.

Vấn đề là tôi không phải là chủ sở hữu của tệp. Eclipse đã được cài đặt trong phiên khác (trên OS X). Tôi có quyền đọc và ghi tệp Eclipse, nhưng tôi không phải là chủ sở hữu. Thực hiện một lệnh "chown" trên tất cả các tệp Eclipse để giải quyết vấn đề. Sau, tôi có kết quả tương tự như Daniel Diaz.

Tôi hi vọng điêu nay se giup được ai đo.

1
defim 2014-07-01 14:41.

CẢNH BÁO

Hiện đã có bản cập nhật cho ADT 23.0.1, nhưng tập lệnh Windows và Linux bị rối loạn, vì vậy hãy đợi bản nâng cấp!

Bạn có thể kiểm tra ví dụ: tools / proguard / bin / *. Sh trong http://dl.google.com/android/android-sdk_r23.0.1-windows.zip .

1
Aldo Israel 2014-08-09 11:53.

Tôi đã làm điều này để giải quyết vấn đề tương tự (trong OS X):

  1. Trợ giúp> Cài đặt Phần mềm Mới> Thêm hoặc chọn kho lưu trữ này " http://download.eclipse.org/eclipse/updates/4.3 "
  2. Trong "Nền tảng Eclipse", hãy chọn phiên bản mới nhất của Eclipse.
  3. Trình cài đặt sẽ hỏi bạn có muốn gỡ cài đặt ADT hay không, hãy nhấp vào kết thúc.
  4. Khởi động lại Eclipse và CHỈ cài đặt ADT 23 bằng cách sử dụng kho lưu trữ này: https://dl-ssl.google.com/android/eclipse .
  5. Khởi động lại Eclipse và cài đặt DDMS, Trình xem phân cấp, Chế độ xem theo dõi, v.v.
  6. Khởi động lại Eclipse một lần nữa.

Hy vọng nó giúp.

1
TurKorsaN 2014-06-28 03:33.

Nếu Eclipse gặp lỗi sau khi gỡ cài đặt plugin ADT khỏi cài đặt Eclipse của bạn, hãy thử chỉnh sửa tệp config.initrong thư mục Eclipse → cấu hình. Tìm thấy:

eclipse.application=

Và thay đổi nó thành:

eclipse.application=org.eclipse.ui.ide.workbench

Hy vọng nó cũng làm việc cho bạn.

1
Carlos F 2014-07-02 22:44.

Tôi chỉ đơn giản là truy cập thư mục tài nguyên Android của mình trên ổ C: / drive ( C:/Android), xóa thư mục 'eclipse' và tất cả nội dung của nó. Tôi đã tải xuống Công cụ dành cho nhà phát triển Android một lần nữa và vừa chuyển qua thư mục 'eclipse'.

Tôi đã khởi động và mọi thứ đều ổn; Tôi đã cập nhật lên phiên bản 23.

Hy vọng rằng điều này sẽ hữu ích, có thể không phù hợp với tất cả mọi người vì một số bạn có sửa đổi Eclipse nhưng đối với một người, như tôi, muốn sửa chữa nhanh chóng và quay lại phát triển đây dường như là con đường dễ dàng nhất.

1
Vamsi Challa 2014-07-15 18:35.

Tôi đang sử dụng Eclipse v4.3 (Kepler) và đây là cách tôi giải quyết vấn đề của mình.

Goto menu Trợ giúpCài đặt phần mềm mới → nhấp vào Thêm .

Trong cửa sổ bật lên, hãy đặt tên bất kỳ (tôi đã đặt tên nó là Plugin ADT Eclipse) và ở vị trí của liên kết, hãy sử dụng https://dl-ssl.google.com/android/eclipse/

Khi bạn nhấp vào OK, bạn sẽ được hiển thị với các gói mới sẽ được cài đặt và các gói cũ sẽ bị xóa. Đừng lo lắng về những gói này. Bấm vào OK.

Các gói mới sẽ được cài đặt và điều này sẽ giải quyết được vấn đề của bạn.

Related questions

MORE COOL STUFF

Cate Blanchett chia tay chồng sau 3 ngày bên nhau và vẫn kết hôn với anh ấy 25 năm sau

Cate Blanchett chia tay chồng sau 3 ngày bên nhau và vẫn kết hôn với anh ấy 25 năm sau

Cate Blanchett đã bất chấp những lời khuyên hẹn hò điển hình khi cô gặp chồng mình.

Tại sao Michael Sheen là một diễn viên phi lợi nhuận

Tại sao Michael Sheen là một diễn viên phi lợi nhuận

Michael Sheen là một diễn viên phi lợi nhuận nhưng chính xác thì điều đó có nghĩa là gì?

Hallmark Star Colin Egglesfield Các món ăn gây xúc động mạnh đối với người hâm mộ tại RomaDrama Live! [Loại trừ]

Hallmark Star Colin Egglesfield Các món ăn gây xúc động mạnh đối với người hâm mộ tại RomaDrama Live! [Loại trừ]

Ngôi sao của Hallmark Colin Egglesfield chia sẻ về những cuộc gặp gỡ với người hâm mộ ly kỳ tại RomaDrama Live! cộng với chương trình INSPIRE của anh ấy tại đại hội.

Tại sao bạn không thể phát trực tuyến 'chương trình truyền hình phía Bắc'

Tại sao bạn không thể phát trực tuyến 'chương trình truyền hình phía Bắc'

Bạn sẽ phải phủi sạch đầu đĩa Blu-ray hoặc DVD để xem tại sao Northern Exposure trở thành một trong những chương trình nổi tiếng nhất của thập niên 90.

Where in the World Are You? Take our GeoGuesser Quiz

Where in the World Are You? Take our GeoGuesser Quiz

The world is a huge place, yet some GeoGuessr players know locations in mere seconds. Are you one of GeoGuessr's gifted elite? Take our quiz to find out!

8 công dụng tuyệt vời của Baking Soda và Giấm

8 công dụng tuyệt vời của Baking Soda và Giấm

Bạn biết đấy, hai sản phẩm này là nguồn điện để làm sạch, riêng chúng. Nhưng cùng với nhau, chúng có một loạt công dụng hoàn toàn khác.

Hạn hán, biến đổi khí hậu đe dọa tương lai của thủy điện Hoa Kỳ

Hạn hán, biến đổi khí hậu đe dọa tương lai của thủy điện Hoa Kỳ

Thủy điện rất cần thiết cho lưới điện của Hoa Kỳ, nhưng nó chỉ tạo ra năng lượng khi có nước di chuyển. Bao nhiêu nhà máy thủy điện có thể gặp nguy hiểm khi các hồ và sông cạn kiệt?

Quyên góp tóc của bạn để giúp giữ nước sạch của chúng tôi

Quyên góp tóc của bạn để giúp giữ nước sạch của chúng tôi

Tóc tỉa từ các tiệm và các khoản quyên góp cá nhân có thể được tái sử dụng như những tấm thảm thấm dầu và giúp bảo vệ môi trường.

Một thương hiệu kế thừa khác có được cuộc sống mới khi những người chủ mới của Black Opal có được Hội chợ thời trang

Một thương hiệu kế thừa khác có được cuộc sống mới khi những người chủ mới của Black Opal có được Hội chợ thời trang

Desiree Rogers, trái, và Cheryl Mayberry McKissack Chuyển sang, Fenty Beauty và Pat McGrath, có một đế chế làm đẹp mới do phụ nữ làm chủ đang trỗi dậy. Sau thương vụ mua lại mỹ phẩm Black Opal vào tháng 9, đội ngũ quyền lực của Giám đốc điều hành công ty Desiree Rogers và Chủ tịch Cheryl Mayberry McKissack đã thông báo mua lại thương hiệu làm đẹp tiên phong Fashion Fair từ người sáng lập Johnson Publishing Company (JPC).

Ngoài việc trở nên vô nghĩa, các bên bộc lộ giới tính giờ đây đã trở nên chết người

Ngoài việc trở nên vô nghĩa, các bên bộc lộ giới tính giờ đây đã trở nên chết người

Đối với những người có quá nhiều thời gian, tiệc tiết lộ giới tính là một cách thú vị để không cần áp đặt những định kiến ​​hạn chế lên thai nhi trước một đối tượng bạn bè giả vờ quan tâm một cách lịch sự. Tuy nhiên, việc chỉ dựa vào những chiếc bánh nướng có màu nhân tạo để biểu thị một tiếng hoo-ha hoặc một đứa trẻ đi tè đã trở nên xa xỉ trong các bậc cha mẹ trên Instagram.

Kirstjen Nielsen đang cố gắng đổi mới bản thân với tư cách là một người phụ nữ 'nói ra sự thật cho sức mạnh'

Kirstjen Nielsen đang cố gắng đổi mới bản thân với tư cách là một người phụ nữ 'nói ra sự thật cho sức mạnh'

Hôm thứ Tư, cựu Bộ trưởng An ninh Nội địa Kirstjen Nielsen vì một lý do nào đó đã được đưa ra một diễn đàn để phát biểu tại Hội nghị thượng đỉnh Những người phụ nữ quyền lực nhất của Fortune. Và có thể đoán trước được, người phụ nữ giám sát các nỗ lực (đang diễn ra) của chính quyền Trump nhằm chia cắt các gia đình ở biên giới đã sử dụng thời gian của mình như một cơ hội để tự bảo vệ mình và tự nhận mình là người — và hãy hít thở sâu ở đây — “đã nói sự thật với quyền lực.

Toyota Racing Development sẽ cho ra mắt Supra 3000GT Concept, Massive Wing vào tháng tới

Toyota Racing Development sẽ cho ra mắt Supra 3000GT Concept, Massive Wing vào tháng tới

Vì thế hệ mới nhất của chiếc xe điều chỉnh được yêu thích trên thế giới hiện đã có mặt tại đây, nên chỉ có điều kiện là Toyota Racing Development sẽ đưa phiên bản Supra thế hệ thứ năm sửa đổi của riêng mình đến SEMA vào tháng tới. Toyota đã cho chúng tôi một gợi ý về những gì sẽ xảy ra trong tuần này: một chiếc Concept GR Supra 3000GT hiện đại.

Nicky Hilton Forced to Borrow Paris' 'I Love Paris' Sweatshirt After 'Airline Loses All [My] Luggage'

Nicky Hilton Forced to Borrow Paris' 'I Love Paris' Sweatshirt After 'Airline Loses All [My] Luggage'

Nicky Hilton Rothschild's luggage got lost, but luckily she has an incredible closet to shop: Sister Paris Hilton's!

Kate Middleton dành một ngày bên bờ nước ở London, cùng với Jennifer Lopez, Julianne Hough và hơn thế nữa

Kate Middleton dành một ngày bên bờ nước ở London, cùng với Jennifer Lopez, Julianne Hough và hơn thế nữa

Kate Middleton dành một ngày bên bờ nước ở London, cùng với Jennifer Lopez, Julianne Hough và hơn thế nữa. Từ Hollywood đến New York và mọi nơi ở giữa, hãy xem các ngôi sao yêu thích của bạn đang làm gì!

17 tuổi bị đâm chết trong khi 4 người khác bị thương trong một cuộc tấn công bằng dao trên sông Wisconsin

17 tuổi bị đâm chết trong khi 4 người khác bị thương trong một cuộc tấn công bằng dao trên sông Wisconsin

Các nhà điều tra đang xem xét liệu nhóm và nghi phạm có biết nhau trước vụ tấn công hay không

Thanh thiếu niên, Gia đình Florida Hội đồng quản trị trường học về Luật 'Không nói đồng tính': 'Buộc chúng tôi tự kiểm duyệt'

Thanh thiếu niên, Gia đình Florida Hội đồng quản trị trường học về Luật 'Không nói đồng tính': 'Buộc chúng tôi tự kiểm duyệt'

Vụ kiện, nêu tên một số học khu, lập luận rằng dự luật "Không nói đồng tính" được ban hành gần đây của Florida "có hiệu quả im lặng và xóa bỏ học sinh và gia đình LGBTQ +"

Đường băng hạ cánh

Đường băng hạ cánh

Cuối hè đầu thu là mùa hoài niệm. Những chiếc đèn đường chiếu ánh sáng của chúng qua những con đường đẫm mưa, và những chiếc lá dưới chân - màu đỏ cam tắt trong bóng chạng vạng - là lời nhắc nhở về những ngày đã qua.

Hãy tưởng tượng tạo ra một chiến lược nội dung thực sự CHUYỂN ĐỔI. Nó có thể.

Hãy tưởng tượng tạo ra một chiến lược nội dung thực sự CHUYỂN ĐỔI. Nó có thể.

Vào năm 2021, tôi khuyến khích bạn suy nghĩ lại mọi thứ bạn biết về khách hàng mà bạn phục vụ và những câu chuyện bạn kể cho họ. Lùi lại.

Sự mất mát của voi ma mút đã mở ra trái tim tôi để yêu

Sự mất mát của voi ma mút đã mở ra trái tim tôi để yêu

Vào ngày sinh nhật thứ 9 của Felix The Cat, tôi nhớ về một trong những mất mát lớn nhất trong cuộc đời trưởng thành của tôi - Sophie của tôi vào năm 2013. Tôi đã viết bài luận này và chia sẻ nó trên nền tảng này một thời gian ngắn vào năm 2013.

Khi bạn không thể trở thành người mà Internet muốn bạn trở thành

Khi bạn không thể trở thành người mà Internet muốn bạn trở thành

Tôi ghét từ "tàu đắm". Mọi người cảm thấy thoải mái trong la bàn đạo đức của riêng mình, và khi làm như vậy, họ thấy mình vượt qua sự phán xét.

Language